summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-01-18 09:40:54 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-01-21 15:02:15 -0500
commit78fe240e7c47f45c87cdfba0107fca6390401137 (patch)
tree67ddd279025d3db265cf9bb24adf0844658c9553 /Makefile.am
parent1183d29d87c5c7439cf2364b7d7324d4a13b6e35 (diff)
downloadsssd-78fe240e7c47f45c87cdfba0107fca6390401137.tar.gz
sssd-78fe240e7c47f45c87cdfba0107fca6390401137.tar.xz
sssd-78fe240e7c47f45c87cdfba0107fca6390401137.zip
Add 'prerelease-rpms' target to Makefile
This target is available only if building from a git checkout. It will automatically populate the PRERELEASE_VERSION in version.m4 with the current datestamp and git commit id for creating an RPM.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b0f8959f1..b5b95824f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,14 @@ rpms: dist-gzip rpmroot
cd $(RPMBUILD); \
rpmbuild --define "_topdir $(RPMBUILD)" -ba SPECS/sssd.spec
+if GIT_CHECKOUT
+prerelease-rpms:
+ cp $(srcdir)/version.m4 $(srcdir)/version.m4.orig
+ sed -e "s/m4_define(\[PRERELEASE_VERSION_NUMBER\], \[.*\])/m4_define(\[PRERELEASE_VERSION_NUMBER\], \[.`date +%Y%m%d`git`git log -1 --pretty=format:%h`\])/" < $(srcdir)/version.m4.orig > $(srcdir)/version.m4
+ $(MAKE) rpms
+ mv $(srcdir)/version.m4.orig $(srcdir)/version.m4
+endif
+
# make srpms will use the old digest algorithm to be compatible
# with RHEL5
srpms: dist-gzip rpmroot