summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-10-13 15:56:46 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-10-14 08:57:28 -0400
commit66e95be41e025398e2b8650888e37d759faa830c (patch)
tree5e2e5f083ed309308feeb858cbb5e05c08e0039f /Makefile.am
parent7c77e790204f82bce88dd6ecd237c941a9389349 (diff)
downloadsssd-66e95be41e025398e2b8650888e37d759faa830c.tar.gz
sssd-66e95be41e025398e2b8650888e37d759faa830c.tar.xz
sssd-66e95be41e025398e2b8650888e37d759faa830c.zip
BUILDSYS: Fix --without-manpages
We weren't honoring the --without-manpages option, and this was causing builds to break. Note: 'make dist[check]' will not work if you have configured with --without-manpages because it will not be able to pre-generate the translation files necessary for tarball release.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c2f1a483c..b9ad98993 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,10 @@
DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb
-SUBDIRS = po src/man
+SUBDIRS = po
+
+if HAVE_MANPAGES
+SUBDIRS += src/man
+endif
# Some old versions of automake don't define builddir
builddir ?= .
@@ -1018,7 +1022,9 @@ endif
# TRANSLATIONS #
################
update-po:
+if HAVE_MANPAGES
$(MAKE) -C src/man update-po
+endif
$(MAKE) -C po update-po
#######################