summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2011-07-12 21:22:22 +0200
committerStephen Gallagher <sgallagh@redhat.com>2011-08-01 12:18:34 -0400
commit833eda9de40ad28e966f8f883dba8e187f8efd32 (patch)
tree997b49118a7b16ed46f2b71108cd6f4aba35380c /Makefile.am
parent38f5e997f02259107016543c9e60f35111cc9aab (diff)
downloadsssd-833eda9de40ad28e966f8f883dba8e187f8efd32.tar.gz
sssd-833eda9de40ad28e966f8f883dba8e187f8efd32.tar.xz
sssd-833eda9de40ad28e966f8f883dba8e187f8efd32.zip
Fix python HBAC bindings for python <= 2.4
Several parts of the HBAC python bindings did not work with old Python versions, such as the one shipped in RHEL5. The changes include: * a compatibility wrapper around python set object * PyModule_AddIntMacro compat macro * Py_ssize_t compat definition * Do not use PyUnicode_FromFormat * several function prototypes and structures used to have "char arguments where they have "const char *" in recent versions. This caused compilation warnings this patch mitigates by using the discard_const hack on python 2.4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index caa7ace58..4e57b7fd2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -311,6 +311,7 @@ dist_noinst_HEADERS = \
src/util/util.h \
src/util/strtonum.h \
src/util/sss_ldap.h \
+ src/util/sss_python.h \
src/util/sss_krb5.h \
src/util/refcount.h \
src/util/find_uid.h \
@@ -998,7 +999,8 @@ pysss_la_LDFLAGS = \
-module
pyhbac_la_SOURCES = \
- src/python/pyhbac.c
+ src/python/pyhbac.c \
+ src/util/sss_python.c
pyhbac_la_CFLAGS = \
$(AM_CFLAGS) \
$(PYTHON_CFLAGS)