summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-07-17 21:08:20 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-09-02 10:39:42 +0200
commit6b5044001e4b0a0caf971a2cf5f27674e0d270f4 (patch)
tree19adf0edd19e578245245767ee51d162d30e3555 /Makefile.am
parent8a5e793a0576250da80371e53aa3e7eba15cdb63 (diff)
downloadsssd-6b5044001e4b0a0caf971a2cf5f27674e0d270f4.tar.gz
sssd-6b5044001e4b0a0caf971a2cf5f27674e0d270f4.tar.xz
sssd-6b5044001e4b0a0caf971a2cf5f27674e0d270f4.zip
Implement MIT Kerberos localauth plugin
The MIT Kerberos localauth pluing interface defines two different calls. The first checks if a given Kerberos principal relates to a given name of a local user (userok). The implementation lets SSSD resolve the principal and the user name and if the returned user entries both have the same UID success is returned. The second translates a given Kerberos principal to a local user name (a2l). Here SSSD is only called once to resolve the principal and the user name is returned. Resolves https://fedorahosted.org/sssd/ticket/1835 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 64c017ea0..1b183d023 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2485,10 +2485,18 @@ endif
if BUILD_KRB5_LOCALAUTH_PLUGIN
sssd_krb5_localauth_plugin_la_SOURCES = \
- src/krb5_plugin/sssd_krb5_localauth_plugin.c
+ src/krb5_plugin/sssd_krb5_localauth_plugin.c \
+ src/util/murmurhash3.c \
+ src/util/io.c \
+ src/sss_client/common.c \
+ src/sss_client/nss_mc_common.c \
+ src/sss_client/nss_mc_passwd.c \
+ src/sss_client/nss_passwd.c
sssd_krb5_localauth_plugin_la_CFLAGS = \
$(AM_CFLAGS) \
$(KRB5_CFLAGS)
+sssd_krb5_localauth_plugin_la_LIBADD = \
+ $(KRB5_LIBS)
sssd_krb5_localauth_plugin_la_LDFLAGS = \
-avoid-version \
-module