summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@redhat.com>2014-02-25 18:31:03 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-05-22 17:36:17 +0200
commit1319e71fd1680ca4864afe0b1aca2b8c8e4a1ee4 (patch)
treec507661a871ac03ca52c477a5a14bc570cfb18c1 /Makefile.am
parente412c809508be9cdd30da679b92ed9f7292357e9 (diff)
downloadsssd-1319e71fd1680ca4864afe0b1aca2b8c8e4a1ee4.tar.gz
sssd-1319e71fd1680ca4864afe0b1aca2b8c8e4a1ee4.tar.xz
sssd-1319e71fd1680ca4864afe0b1aca2b8c8e4a1ee4.zip
SBUS: Start implementing property access
This patch adds the basis of SBUS getters and setters. A new module, sssd_dbus_properties.c would contain handlers for the property methods like Get, Set and GetAll. Type-safe property access works in a similar fashion like type-safe method calls - the invoker calls the getter which returns the primitive type, which is in turn marshalled into variant by the invoker. This patch does not contain the complete functionality, see later patches that continue implementing the getters and setters. Reviewed-by: Stef Walter <stefw@redhat.com> Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 483584e53..138caf841 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -621,6 +621,7 @@ libsss_util_la_SOURCES = \
src/sbus/sssd_dbus_connection.c \
src/sbus/sssd_dbus_meta.c \
src/sbus/sssd_dbus_introspect.c \
+ src/sbus/sssd_dbus_properties.c \
src/sbus/sssd_dbus_request.c \
src/sbus/sssd_dbus_server.c \
src/util/util.c \