summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-01-06 15:27:44 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-05-13 21:46:54 +0200
commitf92ace4a52602e8c38a34f2392bec3deeac2dddd (patch)
treefe8e5c7a5666df507048515073e1ddda447283db /Makefile.am
parent07976be2a09ebb1346c841d4a32e417a8bb43862 (diff)
downloadsssd-f92ace4a52602e8c38a34f2392bec3deeac2dddd.tar.gz
sssd-f92ace4a52602e8c38a34f2392bec3deeac2dddd.tar.xz
sssd-f92ace4a52602e8c38a34f2392bec3deeac2dddd.zip
IFP: Add utility functions
Adds a number of utility functions, most importanly ifp_req_create(). The ifp_req is a structure that will be passed along with the ifp request and would provide easy access to both the sbus_request data and per-responder data, like the ifp_ctx. Also includes a utility function to split a path prefix from a full path and add a ldb_element into a dictionary. These will be reused later. Reviewed-by: Pavel Březina <pbrezina@redhat.com> Reviewed-by: Stef Walter <stefw@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d3a6b5c2f..0af357f14 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -177,7 +177,12 @@ if HAVE_CMOCKA
responder-get-domains-tests \
sbus-internal-tests \
test_search_bases
-endif
+
+if BUILD_IFP
+non_interactive_cmocka_based_tests += ifp_tests
+endif # BUILD_IFP
+
+endif # HAVE_CMOCKA
check_PROGRAMS = \
stress-tests \
@@ -819,6 +824,7 @@ sssd_ifp_SOURCES = \
src/responder/ifp/ifpsrv_cmd.c \
src/responder/ifp/ifp_iface_generated.c \
src/responder/ifp/ifp_iface_generated.h \
+ src/responder/ifp/ifpsrv_util.c \
$(SSSD_UTIL_OBJ) \
$(SSSD_RESPONDER_OBJ)
sssd_ifp_CFLAGS = \
@@ -1699,8 +1705,23 @@ dp_opt_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+if BUILD_IFP
+ifp_tests_SOURCES = \
+ $(TEST_MOCK_RESP_OBJ) \
+ src/tests/cmocka/test_ifp.c \
+ src/responder/ifp/ifpsrv_cmd.c \
+ src/responder/ifp/ifpsrv_util.c
+ifp_tests_CFLAGS = \
+ $(AM_CFLAGS)
+ifp_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
endif
+endif # HAVE_CMOCKA
+
noinst_PROGRAMS = pam_test_client
if BUILD_SUDO
noinst_PROGRAMS += sss_sudo_cli