summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-02-07 15:54:30 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-02-26 15:11:28 +0100
commitf69f3581658351003a6d9245045e41d0efb85022 (patch)
treee3fef2b00370578f9052227d44219537f6ea9bc5 /Makefile.am
parentff6e24f4474cca6226cd44c47ba2ec6ba6cf9a16 (diff)
downloadsssd-f69f3581658351003a6d9245045e41d0efb85022.tar.gz
sssd-f69f3581658351003a6d9245045e41d0efb85022.tar.xz
sssd-f69f3581658351003a6d9245045e41d0efb85022.zip
IPA: refactor idmap code and add test
Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e51003c29..36312fe5e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -162,6 +162,7 @@ if HAVE_CMOCKA
fqnames-tests \
nestedgroups-tests \
test_sss_idmap \
+ test_ipa_idmap \
test_utils \
ad_access_filter_tests \
ad_common_tests \
@@ -1505,6 +1506,20 @@ test_sss_idmap_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+test_ipa_idmap_SOURCES = \
+ src/tests/cmocka/test_ipa_idmap.c \
+ src/providers/ipa/ipa_idmap.c
+test_ipa_idmap_CFLAGS = \
+ $(AM_CFLAGS)
+test_ipa_idmap_LDFLAGS = \
+ -Wl,-wrap,sysdb_get_ranges
+test_ipa_idmap_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ libsss_idmap.la \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
test_utils_SOURCES = \
src/tests/cmocka/test_utils.c
test_utils_CFLAGS = \