summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Březina <pbrezina@redhat.com>2014-01-31 13:30:26 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-02-18 22:59:17 +0100
commite046ae03d0f55b1c8b0ec2fa6139bf86a3449adf (patch)
treea8d6b0a4eca2f3d779ce8e7c5ae25621655bd13f /Makefile.am
parent7139afb1e632a700040c813ebdffe2c177dadc75 (diff)
downloadsssd-e046ae03d0f55b1c8b0ec2fa6139bf86a3449adf.tar.gz
sssd-e046ae03d0f55b1c8b0ec2fa6139bf86a3449adf.tar.xz
sssd-e046ae03d0f55b1c8b0ec2fa6139bf86a3449adf.zip
tests: nested groups unit test
Resolves: https://fedorahosted.org/sssd/ticket/2024 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 134c63f03..b90fecec7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,6 +154,7 @@ if HAVE_CMOCKA
sss_nss_idmap-tests \
dyndns-tests \
fqnames-tests \
+ nestedgroups-tests \
test_sss_idmap \
test_utils \
ad_access_filter_tests \
@@ -1412,6 +1413,19 @@ fqnames_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+nestedgroups_tests_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ $(TEST_MOCK_PROVIDER_OBJ) \
+ src/tests/cmocka/test_nested_groups.c \
+ src/providers/ldap/sdap_async_nested_groups.c
+nestedgroups_tests_CFLAGS = \
+ $(AM_CFLAGS)
+nestedgroups_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
test_sss_idmap_SOURCES = \
src/tests/cmocka/test_sss_idmap.c
test_sss_idmap_CFLAGS = \