summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2012-10-18 16:34:35 +0200
committerSumit Bose <sbose@redhat.com>2012-10-26 10:32:05 +0200
commitdca03a97f4e1532ee2f2cbd26b1538ab6ccf18f7 (patch)
treee581a434e3ae95d078ce05d27d90318d1757af20 /Makefile.am
parent916674f6c54a64980f181790befe861a6e2b8daf (diff)
downloadsssd-dca03a97f4e1532ee2f2cbd26b1538ab6ccf18f7.tar.gz
sssd-dca03a97f4e1532ee2f2cbd26b1538ab6ccf18f7.tar.xz
sssd-dca03a97f4e1532ee2f2cbd26b1538ab6ccf18f7.zip
krb5_child: send PAC to PAC responder
If the authenticated user comes from a different realm the service ticket which was returned during the validation of the TGT is used to extract the PAC which is send to the pac responder for evaluation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ee7e198f1..07dcbd219 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1443,7 +1443,8 @@ krb5_child_SOURCES = \
src/util/sss_krb5.c \
src/util/atomic_io.c \
src/util/util.c \
- src/util/signal.c
+ src/util/signal.c \
+ src/sss_client/common.c
krb5_child_CFLAGS = \
$(AM_CFLAGS) \
$(POPT_CFLAGS) \
@@ -1455,7 +1456,8 @@ krb5_child_LDADD = \
$(TEVENT_LIBS) \
$(POPT_LIBS) \
$(DHASH_LIBS) \
- $(KRB5_LIBS)
+ $(KRB5_LIBS) \
+ $(CLIENT_LIBS)
ldap_child_SOURCES = \
src/providers/ldap/ldap_child.c \