summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-02-26 11:35:24 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-03-02 21:45:22 +0100
commitd206ccb0362396b9de326ab1c43ed3af9d8b60a3 (patch)
treeee0ad150839ec0fec1a447123be9966d5c98bd8e /Makefile.am
parent17f08cbd0f909181536b93d6c12c7cd69995f09e (diff)
downloadsssd-d206ccb0362396b9de326ab1c43ed3af9d8b60a3.tar.gz
sssd-d206ccb0362396b9de326ab1c43ed3af9d8b60a3.tar.xz
sssd-d206ccb0362396b9de326ab1c43ed3af9d8b60a3.zip
config API: prepend source dir search path for tests
Instead of appending the search patch in the source directory should be prepended. Otherwise the test might find files installed in the default paths of the system first. As a result the compiled python files in the build directory must be remove in the clean target to make 'make distcheck' pass. Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 275c899cc..9f010d903 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2308,6 +2308,8 @@ if BUILD_PYTHON_BINDINGS
rm -f $(builddir)/src/config/SSSDConfig/sssd_upgrade_config.py ; \
fi
+ rm -f $(builddir)/src/config/SSSDConfig/*.pyc
+
cd $(builddir)/src/config; $(PYTHON) setup.py build --build-base $(abs_builddir)/src/config clean --all
endif
for doc in $(SSSD_DOCS); do \