summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikolai Kondrashov <Nikolai.Kondrashov@redhat.com>2014-04-15 17:33:08 +0300
committerJakub Hrozek <jhrozek@redhat.com>2014-04-17 13:53:09 +0200
commitc252d148fa8ab50aaaa8bbae7beb4d208025171d (patch)
tree0f51df808b661a65fef9b1fd2d52f87ad3fc2c71 /Makefile.am
parent26ce47cc3e2003c30bae8206c3085f0814c9a842 (diff)
downloadsssd-c252d148fa8ab50aaaa8bbae7beb4d208025171d.tar.gz
sssd-c252d148fa8ab50aaaa8bbae7beb4d208025171d.tar.xz
sssd-c252d148fa8ab50aaaa8bbae7beb4d208025171d.zip
build: Don't assume systemd implies journald
Don't add --with-syslog=journald to extra_distcheck_flags if configured with systemd (--with-initscript=systemd). Add it if configured with journald (--with-syslog=journald) instead. This fixes distcheck target when configured with systemd, but without journald. Don't install journal.conf helping with enabling journald logging, unless configured with journald (--with-syslog=journald), as it would be useless and misleading. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e94d41bc0..3ebb54aed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@ if HAVE_DEVSHM
extra_distcheck_flags += --with-test-dir=/dev/shm
endif
-if HAVE_SYSTEMD_UNIT
+if WITH_JOURNALD
extra_distcheck_flags += --with-syslog=journald
endif
@@ -2198,8 +2198,10 @@ systemdconf_DATA =
if HAVE_SYSTEMD_UNIT
systemdunit_DATA += \
src/sysv/systemd/sssd.service
+if WITH_JOURNALD
systemdconf_DATA += \
src/sysv/systemd/journal.conf
+endif
else
if HAVE_SUSE
init_SCRIPTS += \