summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2014-01-07 15:43:13 -0500
committerJakub Hrozek <jhrozek@redhat.com>2014-02-19 12:29:05 +0100
commit9542512d7be40f2000298c86d3d2b728f4f0f65a (patch)
tree2afe30d9861147f829ec1a99ab6a57cf03db47c5 /Makefile.am
parentb96988a35bfb5f6faf2e364ae966166398afeca3 (diff)
downloadsssd-9542512d7be40f2000298c86d3d2b728f4f0f65a.tar.gz
sssd-9542512d7be40f2000298c86d3d2b728f4f0f65a.tar.xz
sssd-9542512d7be40f2000298c86d3d2b728f4f0f65a.zip
BUILD: Simplify enabling journald on installed systems
systemd supports overrides of the standard service file to be placed in /etc/systemd/system/<service>.service.d/ With this patch, we will install a commented-out override file to /etc that will instruct the user on how to enable logging to journald. Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b90fecec7..d990a8c61 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,10 @@ if HAVE_DEVSHM
extra_distcheck_flags += --with-test-dir=/dev/shm
endif
+if HAVE_SYSTEMD_UNIT
+ extra_distcheck_flags += --with-syslog=journald
+endif
+
DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb \
--enable-all-experimental-features \
$(extra_distcheck_flags)
@@ -51,6 +55,7 @@ pipepath = @pipepath@
mcpath = @mcpath@
initdir = @initdir@
systemdunitdir = @systemdunitdir@
+systemdconfdir = @systemdconfdir@/sssd.service.d
logpath = @logpath@
pubconfpath = @pubconfpath@
pkgconfigdir = $(libdir)/pkgconfig
@@ -2062,9 +2067,12 @@ endif
dist_init_SCRIPTS =
dist_systemdunit_DATA =
+dist_systemdconf_DATA =
if HAVE_SYSTEMD_UNIT
dist_systemdunit_DATA += \
src/sysv/systemd/sssd.service
+ dist_systemdconf_DATA += \
+ src/sysv/systemd/journal.conf
else
if HAVE_SUSE
dist_init_SCRIPTS += \
@@ -2162,6 +2170,7 @@ endif
if HAVE_SYSTEMD_UNIT
mkdir -p $(DESTDIR)$(systemdunitdir)
+ mkdir -p $(DESTDIR)$(systemdconfdir)
else
mkdir -p $(DESTDIR)$(initdir)
endif