summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-02-24 15:42:51 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-02-26 15:24:40 +0100
commit90afedb00608547ae1f32aa7aafd552c4b306909 (patch)
treee63503b5de51afe22bb3599189ca2bdf37c963e9 /Makefile.am
parentddd21d5dc3c89712d9286d1f66f4b2af73651cf2 (diff)
downloadsssd-90afedb00608547ae1f32aa7aafd552c4b306909.tar.gz
sssd-90afedb00608547ae1f32aa7aafd552c4b306909.tar.xz
sssd-90afedb00608547ae1f32aa7aafd552c4b306909.zip
DP: Provide separate dp_copy_defaults function
https://fedorahosted.org/sssd/ticket/2257 Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 36312fe5e..a5b019e40 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -166,6 +166,7 @@ if HAVE_CMOCKA
test_utils \
ad_access_filter_tests \
ad_common_tests \
+ dp_opt_tests \
test_search_bases
endif
@@ -1605,6 +1606,17 @@ ad_common_tests_LDADD = \
libsss_krb5_common.la \
libsss_test_common.la
+dp_opt_tests_SOURCES = \
+ src/providers/data_provider_opts.c \
+ src/tests/cmocka/test_dp_opts.c
+dp_opt_tests_CFLAGS = \
+ $(AM_CFLAGS)
+dp_opt_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
endif
noinst_PROGRAMS = pam_test_client