summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2014-03-17 09:07:56 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-04-16 11:09:52 +0200
commit7fc27c7a3ccbb6aecb8cf4a4a5f91962028cb897 (patch)
tree30c0b58b9acb9693c18f1bf7bead87f919d33b51 /Makefile.am
parent717008c8c3f29f3a1a77266cc72a6cfa616bf295 (diff)
downloadsssd-7fc27c7a3ccbb6aecb8cf4a4a5f91962028cb897.tar.gz
sssd-7fc27c7a3ccbb6aecb8cf4a4a5f91962028cb897.tar.xz
sssd-7fc27c7a3ccbb6aecb8cf4a4a5f91962028cb897.zip
BUILD: Link libsss_ldap_common.so to libsss_idmap.so
Library libsss_ldap.so does not directly use functions from library libsss_idmap.so. It only call function sdap_idmap_init (from file sdap_idmap.c) which is in library libsss_ldap_common.so sh-4.2$ nm -D --undefined-only /usr/lib64/sssd/libsss_ldap.so | grep idmap U sdap_idmap_init On the other hand, libsss_ldap_common.so uses functions from libsss_idmap but it was not linked to libsss_idmap.so. sh-4.2$ objdump -p /usr/lib64/sssd/libsss_ldap_common.so | grep idmap sh-4.2$ echo $? 1 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Simo Sorce <simo@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 295851bc3..e334cdc16 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1823,6 +1823,8 @@ libsss_ldap_common_la_SOURCES = \
src/providers/ldap/sdap_utils.c \
src/providers/ldap/sdap_domain.c \
src/providers/ldap/sdap.c
+libsss_ldap_common_la_LIBADD = \
+ libsss_idmap.la
libsss_ldap_common_la_LDFLAGS = \
-avoid-version
@@ -1884,8 +1886,7 @@ libsss_ldap_la_LIBADD = \
$(DHASH_LIBS) \
$(KRB5_LIBS) \
$(SYSTEMD_LOGIN_LIBS) \
- libsss_ldap_common.la \
- libsss_idmap.la
+ libsss_ldap_common.la
libsss_ldap_la_LDFLAGS = \
-avoid-version \
-module