summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-12-03 20:45:44 +0100
committerJakub Hrozek <jhrozek@redhat.com>2013-12-19 17:39:56 +0100
commit72ae534f5aef6d2e5d3f2f51299aede5abf9687e (patch)
treef95e390ebd6e674415418a127a7fbed0542ffdbb /Makefile.am
parent008e1ee835602023891ac45408483d87f41e4d5c (diff)
downloadsssd-72ae534f5aef6d2e5d3f2f51299aede5abf9687e.tar.gz
sssd-72ae534f5aef6d2e5d3f2f51299aede5abf9687e.tar.xz
sssd-72ae534f5aef6d2e5d3f2f51299aede5abf9687e.zip
AD: Add a utility function to create list of connections
ad_id.c and ad_access.c used the same block of code. With the upcoming option to disable GC lookups, we should unify the code in a function to avoid breaking one of the code paths. The same applies for the LDAP connection to the trusted AD DC. Includes a unit test.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 913e7e6a9..f99588ba8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -155,6 +155,7 @@ if HAVE_CMOCKA
test_sss_idmap \
test_utils \
ad_access_filter_tests \
+ ad_common_tests \
test_search_bases
endif
@@ -1420,6 +1421,7 @@ ad_access_filter_tests_SOURCES = \
src/util/sss_krb5.c \
src/util/find_uid.c \
src/util/user_info_msg.c \
+ src/providers/ad/ad_common.c \
src/tests/cmocka/test_ad_access_filter.c
ad_access_filter_tests_CFLAGS = \
$(AM_CFLAGS) \
@@ -1438,6 +1440,32 @@ ad_access_filter_tests_LDADD = \
libsss_krb5_common.la \
libsss_test_common.la
+ad_common_tests_SOURCES = \
+ $(sssd_be_SOURCES) \
+ src/util/sss_ldap.c \
+ src/util/sss_krb5.c \
+ src/util/find_uid.c \
+ src/util/user_info_msg.c \
+ src/tests/cmocka/test_ad_common.c
+ad_common_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(SYSTEMD_LOGIN_CFLAGS) \
+ -DUNIT_TESTING
+ad_common_tests_LDFLAGS = \
+ -Wl,-wrap,sdap_set_sasl_options
+ad_common_tests_LDADD = \
+ $(PAM_LIBS) \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(CARES_LIBS) \
+ $(KRB5_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(SYSTEMD_LOGIN_LIBS) \
+ libsss_ldap_common.la \
+ libsss_idmap.la \
+ libsss_krb5_common.la \
+ libsss_test_common.la
+
endif
noinst_PROGRAMS = pam_test_client