summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-02-28 10:05:34 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-03-02 20:55:49 +0100
commit61804568ce5ede3b1a699cda17c033dd6c23f0e3 (patch)
treec1e6d101596395835b955be0d60c7f82648acdca /Makefile.am
parentb564424a77c7c3b361c944e0623023d0cfea2c9f (diff)
downloadsssd-61804568ce5ede3b1a699cda17c033dd6c23f0e3.tar.gz
sssd-61804568ce5ede3b1a699cda17c033dd6c23f0e3.tar.xz
sssd-61804568ce5ede3b1a699cda17c033dd6c23f0e3.zip
SUDO: AD provider
This patch adds the sudo target to the AD provider. The main reason is to cover different default settings in the LDAP and AD provider. E.g. the default for ldap_id_mapping is True in the AD provider and False in the LDAP provider. If ldap_id_mapping was not set explicitly in the config file both components worked with different setting. Fixes https://fedorahosted.org/sssd/ticket/2256 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com> Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a861d0eca..31ac8130f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1970,6 +1970,11 @@ libsss_ad_la_SOURCES = \
src/util/sss_krb5.c \
src/util/sss_ldap.c
+if BUILD_SUDO
+libsss_ad_la_SOURCES += \
+ src/providers/ad/ad_sudo.c
+endif
+
libsss_ad_la_CFLAGS = \
$(AM_CFLAGS) \
$(SYSTEMD_LOGIN_CFLAGS) \