summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorYassir Elley <yelley@redhat.com>2014-01-20 11:17:06 -0500
committerJakub Hrozek <jhrozek@redhat.com>2014-05-13 22:17:14 +0200
commit60cab26b12df9a2153823972cde0c38ca86e01b9 (patch)
treecc10c6da23140859116510f50cfa7dedbff48277 /Makefile.am
parent66e1502f956ee71de6cd51c37f7752f8aa14f5f5 (diff)
downloadsssd-60cab26b12df9a2153823972cde0c38ca86e01b9.tar.gz
sssd-60cab26b12df9a2153823972cde0c38ca86e01b9.tar.xz
sssd-60cab26b12df9a2153823972cde0c38ca86e01b9.zip
Implemented LDAP component of GPO-based access control
Reviewed-by: Sumit Bose <sbose@redhat.com> Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0af357f14..2fbb19b6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1671,6 +1671,7 @@ ad_access_filter_tests_LDADD = \
libsss_ldap_common.la \
libsss_idmap.la \
libsss_krb5_common.la \
+ libsss_ad_common.la \
libsss_test_common.la
ad_common_tests_SOURCES = \
@@ -1899,6 +1900,15 @@ libsss_ldap_common_la_SOURCES += \
src/providers/ldap/sdap_async_autofs.c
endif
+pkglib_LTLIBRARIES += libsss_ad_common.la
+libsss_ad_common_la_SOURCES = \
+ $(libsss_ad_la_SOURCES)
+libsss_ad_common_la_LDFLAGS = \
+ -avoid-version
+libsss_ad_common_la_CFLAGS = \
+ $(NDR_NBT_CFLAGS)
+libsss_ad_common_la_LIBADD = \
+ $(NDR_NBT_LIBS)
libsss_krb5_common_la_SOURCES = \
src/providers/krb5/krb5_utils.c \
@@ -2054,6 +2064,8 @@ libsss_ad_la_SOURCES = \
src/providers/ad/ad_id.h \
src/providers/ad/ad_access.c \
src/providers/ad/ad_access.h \
+ src/providers/ad/ad_gpo.c \
+ src/providers/ad/ad_gpo.h \
src/providers/ad/ad_opts.h \
src/providers/ad/ad_srv.c \
src/providers/ad/ad_subdomains.c \