summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2014-03-07 16:46:52 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-03-10 17:35:27 +0100
commit5c36e1f8901a4baff2b51d81d87c2b577f84fef6 (patch)
tree50d76feeb9cef2bd5f0e79cd08fc526d7e073275 /Makefile.am
parent17cd7b7233ff6d84786de316eee307a1c1baf7a7 (diff)
downloadsssd-5c36e1f8901a4baff2b51d81d87c2b577f84fef6.tar.gz
sssd-5c36e1f8901a4baff2b51d81d87c2b577f84fef6.tar.xz
sssd-5c36e1f8901a4baff2b51d81d87c2b577f84fef6.zip
Makefile: Add missing library to the dp_opt_tests
dp_opt_tests cannot be linked properly if link_all_deplibs is disabled (debian) /usr/bin/ld: src/tests/cmocka/dp_opt_tests-test_dp_opts.o: undefined reference to symbol 'poptFreeContext@@LIBPOPT_0' /usr/bin/ld: note: 'poptFreeContext@@LIBPOPT_0' is defined in DSO /lib64/libpopt.so.0 so try adding it to the linker command line /lib64/libpopt.so.0: could not read symbols: Invalid operation Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fba14e49e..750f626d1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1632,6 +1632,7 @@ dp_opt_tests_CFLAGS = \
dp_opt_tests_LDADD = \
$(CMOCKA_LIBS) \
$(TALLOC_LIBS) \
+ $(POPT_LIBS) \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la