summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2014-04-11 00:14:41 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-04-11 20:23:16 +0200
commit4f6931e854c698dcb1c09f99eb330ce2fb97e7c6 (patch)
tree50bcd4e6b66601e7ed4ea710632034529a517246 /Makefile.am
parent8653b547d6142b69c62daa3cd74c251b2b9aecb7 (diff)
downloadsssd-4f6931e854c698dcb1c09f99eb330ce2fb97e7c6.tar.gz
sssd-4f6931e854c698dcb1c09f99eb330ce2fb97e7c6.tar.xz
sssd-4f6931e854c698dcb1c09f99eb330ce2fb97e7c6.zip
AUTOMAKE: Do not include generated files into tarball
sssd.service was assigned to the dist_systemdunit_DATA variable. Automake will install this file into the systemd unit directory after building it if necessary. Automake will also include this generated file in the tarball. As a result, when building sssd from the tarball, the paths needn't be recreated. The files in DATA primaries are added as dependencies to the all target via the internal all-am target. If sssd.service doesn’t exist, make will look for a rule to build it. Since there is such a rule, make will simply execute that rule when I build the all target. Resolves: https://fedorahosted.org/sssd/ticket/2314 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 19e013915..ace2b6528 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -77,7 +77,7 @@ if HAVE_GCC
-std=gnu99
endif
-dist_pkgconfig_DATA =
+pkgconfig_DATA =
ACLOCAL_AMFLAGS = -I m4 -I .
@@ -644,7 +644,7 @@ SSSD_INTERNAL_LTLIBS = \
libsss_child.la
lib_LTLIBRARIES = libipa_hbac.la libsss_idmap.la libsss_nss_idmap.la
-dist_pkgconfig_DATA += src/providers/ipa/ipa_hbac.pc
+pkgconfig_DATA += src/providers/ipa/ipa_hbac.pc
libipa_hbac_la_SOURCES = \
src/providers/ipa/hbac_evaluator.c \
src/util/sss_utf8.c
@@ -653,7 +653,7 @@ libipa_hbac_la_LIBADD = \
libipa_hbac_la_LDFLAGS = \
-version-info 0:1:0
-dist_pkgconfig_DATA += src/lib/idmap/sss_idmap.pc
+pkgconfig_DATA += src/lib/idmap/sss_idmap.pc
libsss_idmap_la_SOURCES = \
src/lib/idmap/sss_idmap.c \
src/lib/idmap/sss_idmap_conv.c \
@@ -661,7 +661,7 @@ libsss_idmap_la_SOURCES = \
libsss_idmap_la_LDFLAGS = \
-version-info 4:0:4
-dist_pkgconfig_DATA += src/sss_client/idmap/sss_nss_idmap.pc
+pkgconfig_DATA += src/sss_client/idmap/sss_nss_idmap.pc
libsss_nss_idmap_la_SOURCES = \
src/sss_client/idmap/sss_nss_idmap.c \
src/sss_client/common.c \
@@ -2226,24 +2226,24 @@ endif
# Installation Extras #
#######################
-dist_init_SCRIPTS =
-dist_systemdunit_DATA =
-dist_systemdconf_DATA =
+init_SCRIPTS =
+systemdunit_DATA =
+systemdconf_DATA =
if HAVE_SYSTEMD_UNIT
- dist_systemdunit_DATA += \
+ systemdunit_DATA += \
src/sysv/systemd/sssd.service
- dist_systemdconf_DATA += \
+ systemdconf_DATA += \
src/sysv/systemd/journal.conf
else
if HAVE_SUSE
- dist_init_SCRIPTS += \
+ init_SCRIPTS += \
src/sysv/SUSE/sssd
else
if HAVE_GENTOO
- dist_init_SCRIPTS += \
+ init_SCRIPTS += \
src/sysv/gentoo/sssd
else
- dist_init_SCRIPTS += \
+ init_SCRIPTS += \
src/sysv/sssd
endif
endif