summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-05-02 19:17:38 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-05-14 16:51:56 +0200
commit3fe339bcba0e211cc666bb3afe34e5c8fce85f4f (patch)
tree5558a375506770e4f1c713c6d27c75827425210e /Makefile.am
parentcf2cc44d6293165379d6470b8bf6bb6a87d62b31 (diff)
downloadsssd-3fe339bcba0e211cc666bb3afe34e5c8fce85f4f.tar.gz
sssd-3fe339bcba0e211cc666bb3afe34e5c8fce85f4f.tar.xz
sssd-3fe339bcba0e211cc666bb3afe34e5c8fce85f4f.zip
IFP: Add a GetGroupsList method
This patch adds a new method on the bus with the following synopsis: <method name="GetUserGroups"> <arg name="user" type="s" direction="in" /> <arg name="values" type="as" direction="out"/> </method> Its purpose is to return names of groups the user is a member of as a list of strings. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a94baf82f..c46bba5da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1753,6 +1753,7 @@ ifp_tests_SOURCES = \
$(TEST_MOCK_RESP_OBJ) \
src/tests/cmocka/test_ifp.c \
src/responder/ifp/ifpsrv_cmd.c \
+ src/responder/ifp/ifp_iface_generated.c \
src/responder/ifp/ifpsrv_util.c
ifp_tests_CFLAGS = \
$(AM_CFLAGS)