summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2013-10-30 12:04:04 +0100
committerJakub Hrozek <jhrozek@redhat.com>2013-10-30 14:19:54 +0100
commit221619d8e8d7cf269c55482e5f466f6511ed35ad (patch)
treeda9cf2f7e52554d7b2bf406123b43571102443d1 /Makefile.am
parent3c77599361395caeffe91ad5b7553f29e7859942 (diff)
downloadsssd-221619d8e8d7cf269c55482e5f466f6511ed35ad.tar.gz
sssd-221619d8e8d7cf269c55482e5f466f6511ed35ad.tar.xz
sssd-221619d8e8d7cf269c55482e5f466f6511ed35ad.zip
Makefile: Add missing libraries
If sssd is compiled with disabled link_all_deplibs (debian) some test could not be properly linked. This patch add missing libraries
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f12e44495..c7e32eb7c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -908,6 +908,8 @@ libsss_test_common_la_SOURCES = \
src/tests/common_dom.c \
src/tests/leak_check.c \
src/tests/common.c
+libsss_test_common_la_LIBADD = \
+ $(TALLOC_LIBS)
if HAVE_CHECK
libsss_test_common_la_SOURCES += \
@@ -1377,6 +1379,7 @@ test_sss_idmap_CFLAGS = \
$(AM_CFLAGS)
test_sss_idmap_LDADD = \
$(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
libsss_idmap.la \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
@@ -1388,6 +1391,7 @@ test_utils_CFLAGS = \
$(AM_CFLAGS)
test_utils_LDADD = \
$(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la