summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@redhat.com>2014-02-25 10:30:06 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-04-19 10:32:50 +0200
commit1203e462650f035b0df2304075d60b9a99e36715 (patch)
tree6f466b47098a4fc66a1f52815b3f59f7f0625a76 /Makefile.am
parentdff909d473f43a6bd0f0286fa2d279c0ebe945c6 (diff)
downloadsssd-1203e462650f035b0df2304075d60b9a99e36715.tar.gz
sssd-1203e462650f035b0df2304075d60b9a99e36715.tar.xz
sssd-1203e462650f035b0df2304075d60b9a99e36715.zip
sbus_codegen_tests: Add test case type-safe handler args
This adds a big test case for invoking a handler with all supported basic arguments, and constructing a reply with the same. Lots of tedious code, but worth it to make sure things work well.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ebb54aed..dc8a99771 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1386,6 +1386,7 @@ sbus_tests_LDADD = \
$(CHECK_LIBS)
sbus_codegen_tests_SOURCES = \
+ src/tests/common_dbus.c \
src/tests/sbus_codegen_tests.c \
src/tests/sbus_codegen_tests_generated.c \
src/tests/sbus_codegen_tests_generated.h