summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikolai Kondrashov <Nikolai.Kondrashov@redhat.com>2014-04-18 14:55:53 +0300
committerJakub Hrozek <jhrozek@redhat.com>2014-04-22 17:22:26 +0200
commit03a071399ab5fb58d4bb4fa38928413a21ae4d61 (patch)
tree73df2c53a7f97af92a81e9f8abb578fdbb7fcb21 /Makefile.am
parent8779b9ee101ed3e5a6836b5366c006dc21dd36c0 (diff)
downloadsssd-03a071399ab5fb58d4bb4fa38928413a21ae4d61.tar.gz
sssd-03a071399ab5fb58d4bb4fa38928413a21ae4d61.tar.xz
sssd-03a071399ab5fb58d4bb4fa38928413a21ae4d61.zip
build: List test extensions
List test extensions with TEST_EXTENSIONS [1] in Makefile.am to allow applying separate LOG_COMPILER for binary and Python tests. This is needed to avoid running Python tests under Valgrind as that produces too many interpreter-specific errors which are hard to suppress reliably [2]. Thus a run like this would run only binary tests under Valgrind: make check PY_LOG_COMPILER=env LOG_COMPILER=valgrind Or more briefly: make check LOG_COMPILER=valgrind [1] http://www.gnu.org/software/automake/manual/automake.html#index-TEST_005fEXTENSIONS [2] http://svn.python.org/projects/python/trunk/Misc/README.valgrind Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dc8a99771..408fb86cf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -191,6 +191,7 @@ PYTHON_TESTS += src/config/SSSDConfigTest.py \
src/tests/pysss_murmur-test.py
endif
+TEST_EXTENSIONS = .py
TESTS = \
$(PYTHON_TESTS) \
$(non_interactive_cmocka_based_tests) \