summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2014-03-04 16:40:36 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-05-16 15:53:50 +0200
commitd1da6541423bcb0e587939945572d29060d0b6a0 (patch)
tree4e78f3d9ad3d5025b2d8f3999507edaf5dd064e6 /Makefile.am
parent1f5eca38ab43953aacb89a4f6dc4c550a0baef9b (diff)
downloadsssd-d1da6541423bcb0e587939945572d29060d0b6a0.tar.gz
sssd-d1da6541423bcb0e587939945572d29060d0b6a0.tar.xz
sssd-d1da6541423bcb0e587939945572d29060d0b6a0.zip
BUILD: Make samba4 libraries optional
Samba 4 libraries are necessary for building {ad, ipa} provider, but samba4 needn't be available on older distributions. This patch add possibility to build SSSD without {ad, ipa} provider and thus without Samba 4 libraries. The script configure have new argument --with-samba with default value yes. Reviewed-by: Michal Židek <mzidek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cbd549a77..154bf38a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -181,10 +181,14 @@ sssdlib_LTLIBRARIES = \
libsss_ldap.la \
libsss_krb5.la \
libsss_proxy.la \
- libsss_ipa.la \
- libsss_ad.la \
libsss_simple.la
+if BUILD_SAMBA
+sssdlib_LTLIBRARIES += \
+ libsss_ipa.la \
+ libsss_ad.la
+endif
+
ldblib_LTLIBRARIES = \
memberof.la