summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikolai Kondrashov <Nikolai.Kondrashov@redhat.com>2014-06-16 19:39:25 +0300
committerJakub Hrozek <jhrozek@redhat.com>2014-06-19 20:41:11 +0200
commitc9ca60fd22c6b77a12a9a7490bbebba4cf2e59a5 (patch)
treef85750982b7f4fbff92b3b7973f83f3e09abb60b /Makefile.am
parentaa5cfe710bb22c1c9d380189b902d46411be113d (diff)
downloadsssd-c9ca60fd22c6b77a12a9a7490bbebba4cf2e59a5.tar.gz
sssd-c9ca60fd22c6b77a12a9a7490bbebba4cf2e59a5.tar.xz
sssd-c9ca60fd22c6b77a12a9a7490bbebba4cf2e59a5.zip
build: Switch back to DISTCHECK_CONFIGURE_FLAGS
Switch back to using DISTCHECK_CONFIGURE_FLAGS instead of the AM_-version in Makefile.am, as the latter is not supported by Automake version in RHEL6. Instead, use a special variable AUX_DISTCHECK_CONFIGURE_FLAGS to augment distcheck target configure flags from the command line. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com> (cherry picked from commit c6e39e15178675d0779e0ae855245774a09b4eb5) Conflicts: Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 4fcbd52f3..03452cd1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,10 +3,11 @@ if HAVE_DEVSHM
extra_distcheck_flags += --with-test-dir=/dev/shm
endif
-AM_DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb \
- --disable-dbus-tests \
- --enable-all-experimental-features \
- $(extra_distcheck_flags)
+DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb \
+ --disable-dbus-tests \
+ --enable-all-experimental-features \
+ $(extra_distcheck_flags) \
+ $(AUX_DISTCHECK_CONFIGURE_FLAGS)
SUBDIRS = po