summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-06-24 17:03:28 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-07-16 17:12:11 +0200
commit80af7e9daed52b283af037864bcdd86d96695618 (patch)
treeeec2093ca102e414b6657149465e6dad85863c6c /Makefile.am
parent42b0c3442815c0374735377c7f5ced4fe1a00e97 (diff)
downloadsssd-80af7e9daed52b283af037864bcdd86d96695618.tar.gz
sssd-80af7e9daed52b283af037864bcdd86d96695618.tar.xz
sssd-80af7e9daed52b283af037864bcdd86d96695618.zip
BUILD: Add the DBus service activation
The system bus has the ability to start services on demant. This patch adds the sysbus service activation file that, currently, only calls the sss_signal tool to signal the monitor. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a678a2590..bf9561cf7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,6 +38,7 @@ sssdconfdir = $(sysconfdir)/sssd
sssddatadir = $(datadir)/sssd
sssdapiplugindir = $(sssddatadir)/sssd.api.d
dbuspolicydir = $(sysconfdir)/dbus-1/system.d
+dbusservicedir = $(datadir)/dbus-1/system-services
localedir = @localedir@
nsslibdir = @nsslibdir@
pamlibdir = @pammoddir@
@@ -809,6 +810,9 @@ sssd_ifp_LDADD = \
$(SSSD_INTERNAL_LTLIBS)
dist_dbuspolicy_DATA = \
src/responder/ifp/org.freedesktop.sssd.infopipe.conf
+dist_dbusservice_DATA = \
+ src/responder/ifp/org.freedesktop.sssd.infopipe.service
+
endif
sssd_be_SOURCES = \
@@ -2256,6 +2260,7 @@ installsssddirs::
$(DESTDIR)$(pluginpath) \
$(DESTDIR)$(libdir)/ldb \
$(DESTDIR)$(dbuspolicydir) \
+ $(DESTDIR)$(dbusservicedir) \
$(DESTDIR)$(pipepath)/private \
$(DESTDIR)$(sssdlibdir) \
$(DESTDIR)$(pkglibdir) \