summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-06-27 17:24:16 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-07-16 17:12:09 +0200
commit42b0c3442815c0374735377c7f5ced4fe1a00e97 (patch)
tree516ffa102f9b8be20395062e67b58e23f13cf7c4 /Makefile.am
parent87d3c7d23885b0b6dca3d7cf0494c7b93225429c (diff)
downloadsssd-42b0c3442815c0374735377c7f5ced4fe1a00e97.tar.gz
sssd-42b0c3442815c0374735377c7f5ced4fe1a00e97.tar.xz
sssd-42b0c3442815c0374735377c7f5ced4fe1a00e97.zip
TOOLS: New helper tool sss_signal
A minimal tool whose only purpose is to signal the monitor with SIGUSR2. The tool will be executed by the system bus in order to provide system activation, so it's packaged in libexec. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7574f9d5b..a678a2590 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,7 +99,9 @@ sssdlibexec_PROGRAMS = \
sssd_be \
krb5_child \
ldap_child \
- proxy_child
+ proxy_child \
+ sss_signal \
+ $(NULL)
if BUILD_SUDO
sssdlibexec_PROGRAMS += sssd_sudo
endif
@@ -934,6 +936,15 @@ sss_seed_LDADD = \
$(TOOLS_LIBS) \
$(SSSD_INTERNAL_LTLIBS)
+sss_signal_SOURCES = \
+ src/tools/sss_signal.c \
+ $(SSSD_TOOLS_OBJ) \
+ $(NULL)
+sss_signal_LDADD = \
+ $(TOOLS_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(NULL)
+
if BUILD_SUDO
sss_sudo_cli_SOURCES = \
src/sss_client/common.c \