summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-01-06 15:27:44 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-06-03 13:31:24 +0200
commitf0875d13c3bd4766eea72b054365abfb9fd610a4 (patch)
tree12a897fbcbfbaf07d99b8a0fa42807ac21c5d3a6 /Makefile.am
parent1cd6f169add862ef24653d2b99fbd6302c27239b (diff)
downloadsssd-f0875d13c3bd4766eea72b054365abfb9fd610a4.tar.gz
sssd-f0875d13c3bd4766eea72b054365abfb9fd610a4.tar.xz
sssd-f0875d13c3bd4766eea72b054365abfb9fd610a4.zip
IFP: Add utility functions
Adds a number of utility functions, most importanly ifp_req_create(). The ifp_req is a structure that will be passed along with the ifp request and would provide easy access to both the sbus_request data and per-responder data, like the ifp_ctx. Also includes a utility function to split a path prefix from a full path and add a ldb_element into a dictionary. These will be reused later. Reviewed-by: Pavel Březina <pbrezina@redhat.com> Reviewed-by: Stef Walter <stefw@redhat.com> (cherry picked from commit f92ace4a52602e8c38a34f2392bec3deeac2dddd)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 65595aa06..a60c97e0f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -165,7 +165,12 @@ if HAVE_CMOCKA
responder-get-domains-tests \
sbus-internal-tests \
test_search_bases
-endif
+
+if BUILD_IFP
+non_interactive_cmocka_based_tests += ifp_tests
+endif # BUILD_IFP
+
+endif # HAVE_CMOCKA
check_PROGRAMS = \
stress-tests \
@@ -788,6 +793,7 @@ sssd_ifp_SOURCES = \
src/responder/ifp/ifpsrv_cmd.c \
src/responder/ifp/ifp_iface_generated.c \
src/responder/ifp/ifp_iface_generated.h \
+ src/responder/ifp/ifpsrv_util.c \
$(SSSD_UTIL_OBJ) \
$(SSSD_RESPONDER_OBJ)
sssd_ifp_CFLAGS = \
@@ -1619,8 +1625,23 @@ dp_opt_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+if BUILD_IFP
+ifp_tests_SOURCES = \
+ $(TEST_MOCK_RESP_OBJ) \
+ src/tests/cmocka/test_ifp.c \
+ src/responder/ifp/ifpsrv_cmd.c \
+ src/responder/ifp/ifpsrv_util.c
+ifp_tests_CFLAGS = \
+ $(AM_CFLAGS)
+ifp_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
endif
+endif # HAVE_CMOCKA
+
noinst_PROGRAMS = pam_test_client
if BUILD_SUDO
noinst_PROGRAMS += sss_sudo_cli