summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@redhat.com>2014-02-18 13:27:20 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-06-02 19:03:26 +0200
commitc672fc52ff2bade73ad735162af9b4eb6fcccdfb (patch)
tree218e22a3ffa0b447709ed6d89f8c77d962c6c9db /Makefile.am
parent1f61185837c26a07cf6196c95631d55d8af0ee40 (diff)
downloadsssd-c672fc52ff2bade73ad735162af9b4eb6fcccdfb.tar.gz
sssd-c672fc52ff2bade73ad735162af9b4eb6fcccdfb.tar.xz
sssd-c672fc52ff2bade73ad735162af9b4eb6fcccdfb.zip
sbus_tests: Add some testing of dispatch and handler code
This starts a DBus server with some handlers, and runs some method calls against it. Note that we don't use the codegen in the sbus_tests, as we sorta want to test this non-codegen related functionality on its own before we run the sbus_codegen_tests. Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Pavel Březina <pbrezina@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com> (cherry picked from commit f5e47e1d65f80ffdb1893feab18583a74d661214) Conflicts: Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 01d199ace..79ab0fda5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -134,6 +134,7 @@ if HAVE_CHECK
ipa_hbac-tests \
sss_idmap-tests \
responder_socket_access-tests \
+ sbus_tests \
sbus_codegen_tests
if BUILD_SSH
@@ -1308,6 +1309,16 @@ krb5_child_test_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+sbus_tests_SOURCES = \
+ src/tests/common_dbus.c \
+ src/tests/sbus_tests.c
+sbus_tests_CFLAGS = \
+ $(CHECK_CFLAGS)
+sbus_tests_LDADD = \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS)
+
sbus_codegen_tests_SOURCES = \
src/tests/sbus_codegen_tests.c \
src/tests/sbus_codegen_tests_generated.c \