summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-05-09 20:03:02 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-06-03 13:31:22 +0200
commitc5651f39ef1660150ffdaed6f35ea14708327adc (patch)
tree6f2802cab5917b4596660721e2b161affcb7253e /Makefile.am
parent40074db97ed4552cf09b1b6d71c19f53d010f80b (diff)
downloadsssd-c5651f39ef1660150ffdaed6f35ea14708327adc.tar.gz
sssd-c5651f39ef1660150ffdaed6f35ea14708327adc.tar.xz
sssd-c5651f39ef1660150ffdaed6f35ea14708327adc.zip
SBUS: Add an async request to retrieve the caller ID
Adds an async request sbus_get_sender_id_{send,recv} that allows retrieval of UID based on "sender" as returned by dbus_message_get_sender(). The UID is an int64_t to be able to use "-1" to as a fallback value for uknown or error cases. The unit test is added as a standalone one, not part of the sbus_tests because the request, and by extension the unit test relies on being connected to the system bus, which is very unlikely to work in a build system. Reviewed-by: Pavel Březina <pbrezina@redhat.com> Reviewed-by: Stef Walter <stefw@redhat.com> (cherry picked from commit 0161a3c5637a0c0092bf54c436bb3d6508d7df26) Conflicts: Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0dfd6003d..65595aa06 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -163,6 +163,7 @@ if HAVE_CMOCKA
ad_common_tests \
dp_opt_tests \
responder-get-domains-tests \
+ sbus-internal-tests \
test_search_bases
endif
@@ -1411,6 +1412,27 @@ responder_get_domains_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+sbus_internal_tests_SOURCES = \
+ src/tests/cmocka/sbus_internal_tests.c \
+ src/sbus/sssd_dbus_request.c
+sbus_internal_tests_CFLAGS = \
+ $(AM_CFLAGS)
+sbus_internal_tests_LDFLAGS = \
+ -Wl,-wrap,dbus_bus_get \
+ -Wl,-wrap,dbus_pending_call_steal_reply \
+ -Wl,-wrap,dbus_pending_call_unref \
+ -Wl,-wrap,dbus_message_unref \
+ -Wl,-wrap,dbus_connection_unref \
+ -Wl,-wrap,dbus_connection_set_exit_on_disconnect \
+ -Wl,-wrap,hash_lookup
+sbus_internal_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ libsss_util.la \
+ libsss_crypt.la \
+ libsss_debug.la \
+ libsss_test_common.la
+
test_find_uid_DEPENDENCIES = \
$(ldblib_LTLIBRARIES)
test_find_uid_SOURCES = \