summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2014-05-27 22:44:17 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-06-03 13:52:35 +0200
commitaf6ac75f077a1bc3a389560db96ca1f04a94a8d6 (patch)
tree675148f7e914be6b0ddde2f490700511a8d43e8e /Makefile.am
parent5791844745bf8d9568b6bd11c4f078b8db8c7986 (diff)
downloadsssd-af6ac75f077a1bc3a389560db96ca1f04a94a8d6.tar.gz
sssd-af6ac75f077a1bc3a389560db96ca1f04a94a8d6.tar.xz
sssd-af6ac75f077a1bc3a389560db96ca1f04a94a8d6.zip
CONFIGURE: Enhance detection of pam
Reviewed-by: Sumit Bose <sbose@redhat.com> (cherry picked from commit d2d21d45a88d0869f860e215c2cf946f032818ca)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9c7fd0485..83ba673da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1652,7 +1652,7 @@ noinst_PROGRAMS += autofs_test_client
endif
pam_test_client_SOURCES = src/sss_client/pam_test_client.c
-pam_test_client_LDADD = -lpam -lpam_misc
+pam_test_client_LDADD = $(PAM_LIBS) $(PAM_MISC_LIBS)
if BUILD_AUTOFS
autofs_test_client_SOURCES = \
@@ -1699,7 +1699,7 @@ pam_sss_la_SOURCES = \
pam_sss_la_LIBADD = \
$(CLIENT_LIBS) \
- -lpam
+ $(PAM_LIBS)
pam_sss_la_LDFLAGS = \
-module \
-avoid-version \