summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2013-10-16 13:23:48 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-04-28 22:17:26 +0200
commit917ff0aa43d3858df1b82f75608601622c12ba57 (patch)
tree44710240d73b6adaf0b6b2ee96e69988de8c0d57 /Makefile.am
parent2ba0b0bbac193b7db5d86e542b506978e63f128f (diff)
downloadsssd-917ff0aa43d3858df1b82f75608601622c12ba57.tar.gz
sssd-917ff0aa43d3858df1b82f75608601622c12ba57.tar.xz
sssd-917ff0aa43d3858df1b82f75608601622c12ba57.zip
BUILD: Link libsss_krb5_common.so to libkeyutils.so
The symbol add_key (from libkeyutils) is used by function add_user_to_delayed_online_authentication (from file src/providers/krb5/krb5_delayed_online_authentication.c) which is part of libsss_krb5_common.so Fixes following error: [sssd[be[default]]] [load_backend_module] (0x0010): Unable to load ad module with path (/usr/lib64/sssd/libsss_ad.so), error: /usr/lib64/sssd/libsss_krb5_common.so: undefined symbol: add_key -lkeyutils was passed to the libraries libsss_{krb5,ipa,ad}.so, but when compiling with -Wl,--as-needed this flag will be ignored, since it is not used directly. So it was unavailable to libsss_krb5_common.so which actually needs it. This patch removes $(KEYUTILS_LIBS) from those libraries and adds it to libsss_krb5_common.so Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Simo Sorce <simo@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b0dce4f73..cbd549a77 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1652,6 +1652,8 @@ libsss_krb5_common_la_SOURCES = \
src/providers/krb5/krb5_access.c \
src/providers/krb5/krb5_child_handler.c \
src/providers/krb5/krb5_init_shared.c
+libsss_krb5_common_la_LIBADD = \
+ $(KEYUTILS_LIBS)
libsss_krb5_common_la_LDFLAGS = \
-avoid-version
libsss_krb5_common_la_CFLAGS = \
@@ -1717,7 +1719,6 @@ libsss_krb5_la_CFLAGS = \
$(KRB5_CFLAGS)
libsss_krb5_la_LIBADD = \
$(DHASH_LIBS) \
- $(KEYUTILS_LIBS) \
$(KRB5_LIBS) \
libsss_krb5_common.la
libsss_krb5_la_LDFLAGS = \
@@ -1770,7 +1771,6 @@ libsss_ipa_la_LIBADD = \
$(OPENLDAP_LIBS) \
$(DHASH_LIBS) \
$(NDR_NBT_LIBS) \
- $(KEYUTILS_LIBS) \
$(KRB5_LIBS) \
libsss_ldap_common.la \
libsss_krb5_common.la \
@@ -1828,7 +1828,6 @@ libsss_ad_la_CFLAGS = \
libsss_ad_la_LIBADD = \
$(OPENLDAP_LIBS) \
$(DHASH_LIBS) \
- $(KEYUTILS_LIBS) \
$(KRB5_LIBS) \
$(NDR_NBT_LIBS) \
libsss_ldap_common.la \