summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-02-28 10:05:34 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-03-02 21:17:59 +0100
commit77cb1c56f13a41d1920efb2946db10a00ed63c9c (patch)
tree80d711d902538acc89f31444d3c90d496204ed1f /Makefile.am
parent056402b9937e43054a3b5780fe9eff2aa9ef84ef (diff)
downloadsssd-77cb1c56f13a41d1920efb2946db10a00ed63c9c.tar.gz
sssd-77cb1c56f13a41d1920efb2946db10a00ed63c9c.tar.xz
sssd-77cb1c56f13a41d1920efb2946db10a00ed63c9c.zip
SUDO: AD provider
This patch adds the sudo target to the AD provider. The main reason is to cover different default settings in the LDAP and AD provider. E.g. the default for ldap_id_mapping is True in the AD provider and False in the LDAP provider. If ldap_id_mapping was not set explicitly in the config file both components worked with different setting. Fixes https://fedorahosted.org/sssd/ticket/2256 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com> Reviewed-by: Pavel Březina <pbrezina@redhat.com> (cherry picked from commit 61804568ce5ede3b1a699cda17c033dd6c23f0e3)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4cc31b4fb..38cf13957 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1804,6 +1804,11 @@ libsss_ad_la_SOURCES = \
src/util/sss_krb5.c \
src/util/sss_ldap.c
+if BUILD_SUDO
+libsss_ad_la_SOURCES += \
+ src/providers/ad/ad_sudo.c
+endif
+
libsss_ad_la_CFLAGS = \
$(AM_CFLAGS) \
$(LDAP_CFLAGS) \