summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-02-07 15:54:30 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-02-26 15:14:38 +0100
commit751a77c04f15e059dcca07f8fd72702db90fb83e (patch)
tree319ebb6b15b32cf33ba9a3806e1345c5516253c1 /Makefile.am
parentb71e463bb8dca5aaca8e9677a92b679390c7b966 (diff)
downloadsssd-751a77c04f15e059dcca07f8fd72702db90fb83e.tar.gz
sssd-751a77c04f15e059dcca07f8fd72702db90fb83e.tar.xz
sssd-751a77c04f15e059dcca07f8fd72702db90fb83e.zip
IPA: refactor idmap code and add test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 101401f3c..f490bc39a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -150,6 +150,7 @@ if HAVE_CMOCKA
dyndns-tests \
fqnames-tests \
test_sss_idmap \
+ test_ipa_idmap \
test_utils \
ad_access_filter_tests \
ad_common_tests \
@@ -1356,6 +1357,20 @@ test_sss_idmap_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+test_ipa_idmap_SOURCES = \
+ src/tests/cmocka/test_ipa_idmap.c \
+ src/providers/ipa/ipa_idmap.c
+test_ipa_idmap_CFLAGS = \
+ $(AM_CFLAGS)
+test_ipa_idmap_LDFLAGS = \
+ -Wl,-wrap,sysdb_get_ranges
+test_ipa_idmap_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ libsss_idmap.la \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
test_utils_SOURCES = \
src/tests/cmocka/test_utils.c
test_utils_CFLAGS = \