summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@redhat.com>2014-02-25 10:30:06 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-06-03 13:20:03 +0200
commit70dd9c63ba4ee1e115c7194bc1f1bf0b757034ba (patch)
treedf904b9c7522709f7bcf4e2e2005bd36756f8388 /Makefile.am
parente38c58d968594cb466163e64a43a7bfb959e48b0 (diff)
downloadsssd-70dd9c63ba4ee1e115c7194bc1f1bf0b757034ba.tar.gz
sssd-70dd9c63ba4ee1e115c7194bc1f1bf0b757034ba.tar.xz
sssd-70dd9c63ba4ee1e115c7194bc1f1bf0b757034ba.zip
sbus_codegen_tests: Add test case type-safe handler args
This adds a big test case for invoking a handler with all supported basic arguments, and constructing a reply with the same. Lots of tedious code, but worth it to make sure things work well. (cherry picked from commit 1203e462650f035b0df2304075d60b9a99e36715)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ddf2ff18..0dfd6003d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1350,6 +1350,7 @@ sbus_tests_LDADD = \
$(CHECK_LIBS)
sbus_codegen_tests_SOURCES = \
+ src/tests/common_dbus.c \
src/tests/sbus_codegen_tests.c \
src/tests/sbus_codegen_tests_generated.c \
src/tests/sbus_codegen_tests_generated.h