summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-05-02 19:17:38 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-06-03 13:37:06 +0200
commit64f5e4b48926c9c14994e73c5a950a5ac876ec8e (patch)
treeb17e73ca49261a0be00b41d5e05d8076413e17d8 /Makefile.am
parentbd8cf980dc2e7035a8ce893df4a8ccaf9bbf11ad (diff)
downloadsssd-64f5e4b48926c9c14994e73c5a950a5ac876ec8e.tar.gz
sssd-64f5e4b48926c9c14994e73c5a950a5ac876ec8e.tar.xz
sssd-64f5e4b48926c9c14994e73c5a950a5ac876ec8e.zip
IFP: Add a GetGroupsList method
This patch adds a new method on the bus with the following synopsis: <method name="GetUserGroups"> <arg name="user" type="s" direction="in" /> <arg name="values" type="as" direction="out"/> </method> Its purpose is to return names of groups the user is a member of as a list of strings. Reviewed-by: Pavel Březina <pbrezina@redhat.com> (cherry picked from commit 3fe339bcba0e211cc666bb3afe34e5c8fce85f4f)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ff95518a5..2ec384a34 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1630,6 +1630,7 @@ ifp_tests_SOURCES = \
$(TEST_MOCK_RESP_OBJ) \
src/tests/cmocka/test_ifp.c \
src/responder/ifp/ifpsrv_cmd.c \
+ src/responder/ifp/ifp_iface_generated.c \
src/responder/ifp/ifpsrv_util.c
ifp_tests_CFLAGS = \
$(AM_CFLAGS)