summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-04-15 17:24:55 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-06-03 11:28:05 +0200
commit4f3e9da9a27624017866579701dd9f30b976a533 (patch)
tree8abca2468c95210bc974eccc3ea157053e8e269a /Makefile.am
parent230eff7da668b8e79dda3742a0dac4ad857106fe (diff)
downloadsssd-4f3e9da9a27624017866579701dd9f30b976a533.tar.gz
sssd-4f3e9da9a27624017866579701dd9f30b976a533.tar.xz
sssd-4f3e9da9a27624017866579701dd9f30b976a533.zip
RESPONDERS: Add a new request sss_parse_inp_send
The responders were copying code to parse input and on encountering an uknown domain, send the discover subdomain request. This patch adds a reusable request that can always be called in responders and in case the name can be parsed, just shortcut. Reviewed-by: Pavel Březina <pbrezina@redhat.com> (cherry picked from commit 7caf7ed4f2eae1ec1c0717b4ee6ce78bdacd5926) Conflicts: Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3996a9054..1aef2647b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -162,6 +162,7 @@ if HAVE_CMOCKA
ad_access_filter_tests \
ad_common_tests \
dp_opt_tests \
+ responder-get-domains-tests \
test_search_bases
endif
@@ -1388,6 +1389,22 @@ nss_srv_tests_LDADD = \
libsss_test_common.la \
libsss_idmap.la
+EXTRA_responder_get_domains_tests_DEPENDENCIES = \
+ $(ldblib_LTLIBRARIES)
+responder_get_domains_tests_SOURCES = \
+ src/responder/common/responder_get_domains.c \
+ src/tests/cmocka/test_responder_common.c \
+ src/tests/cmocka/common_mock_resp.c
+responder_get_domains_tests_CFLAGS = \
+ $(AM_CFLAGS)
+responder_get_domains_tests_LDFLAGS = \
+ -Wl,-wrap,sss_parse_name_for_domains
+responder_get_domains_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
test_find_uid_DEPENDENCIES = \
$(ldblib_LTLIBRARIES)
test_find_uid_SOURCES = \