summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2013-10-15 10:27:36 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-05-18 04:55:35 +0200
commit43975eaed128924e7999757eea1708487178d317 (patch)
tree5554998d8b1b7c5804c7eda74ef8f7fa17135450 /Makefile.am
parent07e242624e004657d563cc78634ad666e3abf4af (diff)
downloadsssd-43975eaed128924e7999757eea1708487178d317.tar.gz
sssd-43975eaed128924e7999757eea1708487178d317.tar.xz
sssd-43975eaed128924e7999757eea1708487178d317.zip
BUILD: Explicitly link libsss_ad.so with sasl libs
If openldap is not built with sasl support libsss_ad.so will not be linked with libsasl2 although sasl_client_init is called by function ad_sasl_initialize. (cherry picked from commit c3889e5a101a075defe533d81f5296d5e680f639)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 154bf38a4..8d92326de 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1826,11 +1826,13 @@ endif
libsss_ad_la_CFLAGS = \
$(AM_CFLAGS) \
$(LDAP_CFLAGS) \
+ $(SASL_CFLAGS) \
$(DHASH_CFLAGS) \
$(KRB5_CFLAGS) \
$(NDR_NBT_CFLAGS)
libsss_ad_la_LIBADD = \
$(OPENLDAP_LIBS) \
+ $(SASL_LIBS) \
$(DHASH_LIBS) \
$(KRB5_LIBS) \
$(NDR_NBT_LIBS) \