summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-01-06 15:15:40 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-06-03 10:45:44 +0200
commit413c80baf48a78874134604de190c7bc491b5d43 (patch)
tree692cc4b0a45a09b68e5b7a7177d3ac1bb834456d /Makefile.am
parentfd6ab0a538639a78d10c296e3358a95427418978 (diff)
downloadsssd-413c80baf48a78874134604de190c7bc491b5d43.tar.gz
sssd-413c80baf48a78874134604de190c7bc491b5d43.tar.xz
sssd-413c80baf48a78874134604de190c7bc491b5d43.zip
IFP: Connect to the system bus
Related: https://fedorahosted.org/sssd/ticket/2072 Adds the possibility for the InfoPipe responder to connect to the system bus. At the moment, only a dummy method "Ping" is provided. The method only accepts a single string parameter that has to be 'ping'. (cherry picked from commit 8214510f125879c3b1d247f2ce981ee20b5375d1)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dce820423..19d9bfb18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,6 +36,7 @@ sssdconfdir = $(sysconfdir)/sssd
sssddatadir = $(datadir)/sssd
sssdapiplugindir = $(sssddatadir)/sssd.api.d
dbusintrospectdir = $(datarootdir)/sssd/introspect
+dbuspolicydir = $(sysconfdir)/dbus-1/system.d
localedir = @localedir@
nsslibdir = @nsslibdir@
pamlibdir = @pammoddir@
@@ -660,7 +661,8 @@ include_HEADERS = \
CODEGEN_XML = \
$(srcdir)/src/tests/sbus_codegen_tests.xml \
$(srcdir)/src/monitor/monitor_iface.xml \
- $(srcdir)/src/providers/data_provider_iface.xml
+ $(srcdir)/src/providers/data_provider_iface.xml \
+ $(srcdir)/src/responder/ifp/ifp_iface.xml
SBUS_CODEGEN = src/sbus/sbus_codegen
@@ -782,6 +784,8 @@ if BUILD_IFP
sssd_ifp_SOURCES = \
src/responder/ifp/ifpsrv.c \
src/responder/ifp/ifpsrv_cmd.c \
+ src/responder/ifp/ifp_iface_generated.c \
+ src/responder/ifp/ifp_iface_generated.h \
$(SSSD_UTIL_OBJ) \
$(SSSD_RESPONDER_OBJ)
sssd_ifp_CFLAGS = \
@@ -789,6 +793,8 @@ sssd_ifp_CFLAGS = \
sssd_ifp_LDADD = \
$(SSSD_LIBS) \
$(SSSD_INTERNAL_LTLIBS)
+dist_dbuspolicy_DATA = \
+ src/responder/ifp/org.freedesktop.sssd.infopipe.conf
endif
sssd_be_SOURCES = \
@@ -2163,6 +2169,7 @@ installsssddirs::
$(DESTDIR)$(pluginpath) \
$(DESTDIR)$(libdir)/ldb \
$(DESTDIR)$(dbusintrospectdir) \
+ $(DESTDIR)$(dbuspolicydir) \
$(DESTDIR)$(pipepath)/private \
$(DESTDIR)$(sssdlibdir) \
$(DESTDIR)$(pkglibdir) \