summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-06-19 10:50:44 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-06-28 22:22:20 +0200
commitf8a4a5f6240156809e1b5ef03816f673281e3fa0 (patch)
tree4963a9bbe4f56c50093df9f826fa7a268b6fd335 /Makefile.am
parent59415636c92c6e9764ddc65a85ad61002310519d (diff)
downloadsssd-f8a4a5f6240156809e1b5ef03816f673281e3fa0.tar.gz
sssd-f8a4a5f6240156809e1b5ef03816f673281e3fa0.tar.xz
sssd-f8a4a5f6240156809e1b5ef03816f673281e3fa0.zip
IPA: Initialize server mode ctx if server mode is on
This patch introduces a new structure that holds information about a subdomain and its ad_id_ctx. This structure will be used only in server mode to make it possible to search subdomains with a particular ad_id_ctx. Subtask of: https://fedorahosted.org/sssd/ticket/1962
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index da1d26c6d..515843420 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1575,6 +1575,11 @@ libsss_ipa_la_SOURCES = \
src/providers/ipa/ipa_selinux_common.c \
src/providers/ipa/ipa_srv.c \
src/providers/ipa/ipa_idmap.c \
+ src/providers/ad/ad_common.c \
+ src/providers/ad/ad_common.h \
+ src/providers/ad/ad_dyndns.c \
+ src/providers/ad/ad_id.c \
+ src/providers/ad/ad_srv.c \
src/util/user_info_msg.c \
src/util/find_uid.c \
src/util/sss_ldap.c \
@@ -1583,10 +1588,12 @@ libsss_ipa_la_CFLAGS = \
$(AM_CFLAGS) \
$(LDAP_CFLAGS) \
$(DHASH_CFLAGS) \
+ $(NDR_NBT_CFLAGS)
$(KRB5_CFLAGS)
libsss_ipa_la_LIBADD = \
$(OPENLDAP_LIBS) \
$(DHASH_LIBS) \
+ $(NDR_NBT_LIBS) \
$(KEYUTILS_LIBS) \
$(KRB5_LIBS) \
libsss_ldap_common.la \