summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2013-08-31 08:50:47 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-09-09 16:23:52 +0200
commiteaa723b4d06b4c1e588df67bef44a84bbfaebf1a (patch)
tree1d7b656f678da76cb14a74cd7f92e2f7a392e483 /Makefile.am
parentccf340e56364851f2e5b75e52d3d63701b662954 (diff)
downloadsssd-eaa723b4d06b4c1e588df67bef44a84bbfaebf1a.tar.gz
sssd-eaa723b4d06b4c1e588df67bef44a84bbfaebf1a.tar.xz
sssd-eaa723b4d06b4c1e588df67bef44a84bbfaebf1a.zip
AUTOMAKE: Use portable way to link with gettext
Function gettext needn't be included in libc, it can be part of another library. Autotools macro AM_GNU_GETTEXT generate makefile variables (LIBINTL, LTLIBINTL), which contain necessary linker flags. checking for GNU gettext in libc... no checking for iconv... yes checking for GNU gettext in libintl... yes checking whether to use NLS... yes checking where the gettext function comes from... external libintl
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e45e69fe8..b6d2fd0d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -357,6 +357,7 @@ PYTHON_BINDINGS_LIBS = \
$(TDB_LIBS)
TOOLS_LIBS = \
+ $(LTLIBINTL) \
$(TALLOC_LIBS) \
$(TEVENT_LIBS) \
$(POPT_LIBS) \
@@ -507,8 +508,10 @@ if BUILD_SUDO
SSSD_DOCS += libsss_sudo_doc
endif
+CLIENT_LIBS = $(LTLIBINTL)
+
if HAVE_PTHREAD
-CLIENT_LIBS = -lpthread
+CLIENT_LIBS += -lpthread
endif
#####################