summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Reichl <pavel.reichl@redhat.com>2013-11-14 21:52:26 +0000
committerJakub Hrozek <jhrozek@redhat.com>2013-11-29 15:55:43 +0100
commitd0f9bd3ac24b97b85126c880cf8fe99a356cb5a3 (patch)
tree7d7972d02981fb0379cf8ebefa8c969b2b47275a /Makefile.am
parent7417b20fb2755c12c372e288e3c8a64113f6c9a3 (diff)
downloadsssd-d0f9bd3ac24b97b85126c880cf8fe99a356cb5a3.tar.gz
sssd-d0f9bd3ac24b97b85126c880cf8fe99a356cb5a3.tar.xz
sssd-d0f9bd3ac24b97b85126c880cf8fe99a356cb5a3.zip
SSSD: Unit test - sss_ldap_dn_in_search_bases
Unit test testing detection of the right domain when processing group with members from several domains Resolves: https://fedorahosted.org/sssd/ticket/2132
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3dcb9e697..4452566ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,7 +151,8 @@ if HAVE_CMOCKA
fqnames-tests \
test_sss_idmap \
test_utils \
- ad_access_filter_tests
+ ad_access_filter_tests \
+ test_search_bases
endif
check_PROGRAMS = \
@@ -1364,6 +1365,30 @@ test_utils_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+test_search_bases_SOURCES = \
+ $(sssd_be_SOURCES) \
+ src/util/sss_ldap.c \
+ src/util/sss_krb5.c \
+ src/util/find_uid.c \
+ src/util/user_info_msg.c \
+ src/tests/cmocka/test_search_bases.c
+test_search_bases_CFLAGS = \
+ $(AM_CFLAGS) \
+ -DUNIT_TESTING
+test_search_bases_LDADD = \
+ $(PAM_LIBS) \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(SSSD_LIBS) \
+ $(CARES_LIBS) \
+ $(KRB5_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(SYSTEMD_LOGIN_LIBS) \
+ libsss_ldap_common.la \
+ libsss_idmap.la \
+ libsss_krb5_common.la \
+ libsss_test_common.la
+
ad_access_filter_tests_SOURCES = \
$(sssd_be_SOURCES) \
src/util/sss_ldap.c \