summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAbhishek Singh <abhishekkumarsingh.cse@gmail.com>2013-03-23 01:42:48 +0530
committerJakub Hrozek <jhrozek@redhat.com>2013-04-10 14:21:23 +0200
commitae6c1596225c65bec2a2dabff9eee4e3e0691181 (patch)
tree8532882d4967d2a41ee768216902512223221461 /Makefile.am
parenta65a64aee968bd2ac18156ced15a1e2509a8acba (diff)
downloadsssd-ae6c1596225c65bec2a2dabff9eee4e3e0691181.tar.gz
sssd-ae6c1596225c65bec2a2dabff9eee4e3e0691181.tar.xz
sssd-ae6c1596225c65bec2a2dabff9eee4e3e0691181.zip
cmocka unittest for io added
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e12b769ce..3209cbab3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,7 +147,8 @@ endif
if HAVE_CMOCKA
non_interactive_cmocka_based_tests = \
nss-srv-tests \
- test-find-uid
+ test-find-uid \
+ test-io
endif
check_PROGRAMS = \
@@ -1233,6 +1234,14 @@ test_find_uid_LDADD = \
$(DHASH_LIBS) \
$(CMOCKA_LIBS) \
libsss_util.la
+
+test_io_SOURCES = \
+ src/tests/cmocka/test_io.c \
+ src/util/io.c
+test_io_CFLAGS = \
+ $(AM_CFLAGS)
+test_io_LDADD = \
+ $(CMOCKA_LIBS)
endif
noinst_PROGRAMS = pam_test_client