summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2013-05-10 09:55:31 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-06-06 23:58:56 +0200
commit92af6f25864b5c389b57d0f659686801b45ca58c (patch)
tree739bd3da9da35820d45c2b2c4bdb0c65ae8777d4 /Makefile.am
parent3680bb9c72ea5c60e6ac2fd2cf500b801341ca59 (diff)
downloadsssd-92af6f25864b5c389b57d0f659686801b45ca58c.tar.gz
sssd-92af6f25864b5c389b57d0f659686801b45ca58c.tar.xz
sssd-92af6f25864b5c389b57d0f659686801b45ca58c.zip
Enhance PAC responder for AD users
This patch modifies the PAC responder so that it can be used with the AD provider as well. The main difference is that the POSIX UIDs and GIDs are now lookup up with the help of the SID instead of being calculated algorithmically. This was necessary because the AD provider allows either algorithmic mapping or reading the value from attributes stored in AD. Fixes https://fedorahosted.org/sssd/ticket/1558
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 0 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index 71ddf05d1..b5cc58971 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -134,10 +134,6 @@ if HAVE_CHECK
sss_idmap-tests \
responder_socket_access-tests
-if BUILD_PAC_RESPONDER
- non_interactive_check_based_tests += pac_responder-tests
-endif
-
if BUILD_SSH
non_interactive_check_based_tests += sysdb_ssh-tests
endif
@@ -1152,23 +1148,6 @@ sss_idmap_tests_LDADD = \
libsss_test_common.la \
libsss_idmap.la
-pac_responder_tests_SOURCES = \
- src/tests/pac_responder-tests.c \
- src/responder/pac/pacsrv_utils.c
-pac_responder_tests_CFLAGS = \
- $(AM_CFLAGS) \
- $(NDR_KRB5PAC_CFLAGS) \
- $(CHECK_CFLAGS)
-pac_responder_tests_LDADD = \
- $(CHECK_LIBS) \
- $(TALLOC_LIBS) \
- $(NDR_KRB5PAC_LIBS) \
- $(SSSD_LIBS) \
- -lm \
- libsss_idmap.la \
- $(SSSD_INTERNAL_LTLIBS) \
- libsss_test_common.la
-
responder_socket_access_tests_SOURCES = \
src/tests/responder_socket_access-tests.c \
src/responder/common/responder_common.c \