summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-02-24 15:42:51 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-02-26 15:29:12 +0100
commit802220cc4ef437d8f169c51c7ce073a51f507b92 (patch)
tree157300c0f4e35fdd4d3d20fd31884d831cae0d96 /Makefile.am
parentd07cb60c1f4b9a7e1618b50ca2fc817298e5db12 (diff)
downloadsssd-802220cc4ef437d8f169c51c7ce073a51f507b92.tar.gz
sssd-802220cc4ef437d8f169c51c7ce073a51f507b92.tar.xz
sssd-802220cc4ef437d8f169c51c7ce073a51f507b92.zip
DP: Provide separate dp_copy_defaults function
https://fedorahosted.org/sssd/ticket/2257 Reviewed-by: Pavel Březina <pbrezina@redhat.com> (cherry picked from commit 90afedb00608547ae1f32aa7aafd552c4b306909)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f490bc39a..d9d41df5f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,6 +154,7 @@ if HAVE_CMOCKA
test_utils \
ad_access_filter_tests \
ad_common_tests \
+ dp_opt_tests \
test_search_bases
endif
@@ -1456,6 +1457,17 @@ ad_common_tests_LDADD = \
libsss_krb5_common.la \
libsss_test_common.la
+dp_opt_tests_SOURCES = \
+ src/providers/data_provider_opts.c \
+ src/tests/cmocka/test_dp_opts.c
+dp_opt_tests_CFLAGS = \
+ $(AM_CFLAGS)
+dp_opt_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
endif
noinst_PROGRAMS = pam_test_client