summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2013-05-02 20:28:30 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-05-07 14:12:06 +0200
commit4cdaf239d4504966bed8ecd5e3fa07def74c7302 (patch)
tree34ceec2ae3c01723e4337e09718569d786d8ed13 /Makefile.am
parent41bfa213a0994cebcef5f69fd2c353136c803ae4 (diff)
downloadsssd-4cdaf239d4504966bed8ecd5e3fa07def74c7302.tar.gz
sssd-4cdaf239d4504966bed8ecd5e3fa07def74c7302.tar.xz
sssd-4cdaf239d4504966bed8ecd5e3fa07def74c7302.zip
AD: read flat name and SID of the AD domain
For various features either the flat/short/NetBIOS domain name or the domain SID is needed. Since the responders already try to do a subdomain lookup when and known domain name is encountered I added a subdomain lookup to the AD provider which currently only reads the SID from the base DN and the NetBIOS name from a reply of a LDAP ping. The results are written to the cache to have them available even if SSSD is started in offline mode. Looking up trusted domains can be added later. Since all the needed responder code is already available from the corresponding work for the IPA provider this patch fixes https://fedorahosted.org/sssd/ticket/1468
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3abea76c1..b72384a77 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1621,6 +1621,8 @@ libsss_ad_la_SOURCES = \
src/providers/ad/ad_access.h \
src/providers/ad/ad_opts.h \
src/providers/ad/ad_srv.c \
+ src/providers/ad/ad_subdomains.c \
+ src/providers/ad/ad_subdomains.h \
src/util/find_uid.c \
src/util/user_info_msg.c \
src/util/sss_krb5.c \