summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2014-04-04 10:13:44 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-04-04 17:45:52 +0200
commit1f4df57b153c231c85a63993219cb8315bec282a (patch)
tree7f8b7e946f1f493e8df8665af2c0b21e25a2a62a /Makefile.am
parentbda38dde09b6975495437620d8c10f39e41af7be (diff)
downloadsssd-1f4df57b153c231c85a63993219cb8315bec282a.tar.gz
sssd-1f4df57b153c231c85a63993219cb8315bec282a.tar.xz
sssd-1f4df57b153c231c85a63993219cb8315bec282a.zip
Makefile: Use alternative method to replace *bindir
https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/Installation-Directory-Variables.html Most of these variables have values that rely on prefix or exec_prefix. It is deliberate that the directory output variables keep them unexpanded: typically ‘@sbindir@’ is replaced by ‘${exec_prefix}/sbin’, not ‘/usr/local/sbin’. This behavior is mandated by the GNU Coding Standards. Installation directory variables (sbindir, pkgdatadir ...) should be used only in makefiles. Similarly, we should not rely on AC_CONFIG_FILES to replace sbindir and friends in shell scripts and other files; instead, let make manage their replacement. Resolves: https://fedorahosted.org/sssd/ticket/2293 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9056f29d7..5abaf1778 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2032,6 +2032,26 @@ dist_sssdapiplugin_DATA = \
src/config/etc/sssd.api.d/sssd-proxy.conf \
src/config/etc/sssd.api.d/sssd-simple.conf
+edit_cmd = $(SED) \
+ -e 's|@sbindir[@]|$(sbindir)|g' \
+ -e 's|@environment_file[@]|$(environment_file)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g' \
+ -e 's|@prefix[@]|$(prefix)|g'
+
+replace_script = \
+ @rm -f $@ $@.tmp; \
+ srcdir=''; \
+ test -f ./$@.in || srcdir=$(srcdir)/; \
+ $(edit_cmd) $${srcdir}$@.in >$@.tmp; \
+ mv $@.tmp $@
+
+EXTRA_DIST += \
+ src/sysv/systemd/sssd.service.in
+
+src/sysv/systemd/sssd.service: src/sysv/systemd/sssd.service.in Makefile
+ @$(MKDIR_P) src/sysv/systemd/
+ $(replace_script)
+
installsssddirs::
mkdir -p \
$(DESTDIR)$(includedir) \
@@ -2139,6 +2159,7 @@ endif
rm -Rf $$doc; \
done;
rm -Rf ldb_mod_test_dir
+ rm -f $(builddir)/src/sysv/systemd/sssd.service
CLEANFILES = *.X */*.X */*/*.X