summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-06-05 12:02:35 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-06-07 00:35:25 +0200
commite293fba4f5459f3c2dad254dcc966407d8fc3312 (patch)
tree36f13d9d5bc1b9361f907fda34828e7f6fc717df /Makefile.am
parent2a40ee7639baff182bb516d1e3d6effaf8e7619e (diff)
downloadsssd-e293fba4f5459f3c2dad254dcc966407d8fc3312.tar.gz
sssd-e293fba4f5459f3c2dad254dcc966407d8fc3312.tar.xz
sssd-e293fba4f5459f3c2dad254dcc966407d8fc3312.zip
rpm: Fold libsss_sudo and libsss_autofs back into the main SSSD package
https://fedorahosted.org/sssd/ticket/1845 libsss_sudo and libsss_autofs are separate packages that contain just a single client library with no additional dependencies. This separation comes from the F-17 timeframe where the feature was really just a tech preview so we didn't want it to be packaged in sssd proper. On the other hand users are getting regularly confused about "sudo not working" when all they really miss is the single library. This patch moves the files owned by the libsss_autofs and libsss_sudo packages back to the main sssd package. We also no longer build the libsss_sudo documentation by default and do not ship the header file as it was just a private one.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index a201abf20..6b0397357 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -483,6 +483,7 @@ dist_noinst_HEADERS = \
src/tests/cmocka/common_mock.h \
src/tests/cmocka/common_mock_resp.h \
src/sss_client/ssh/sss_ssh_client.h \
+ src/sss_client/sudo/sss_sudo.h \
src/lib/idmap/sss_idmap_private.h
@@ -1370,8 +1371,6 @@ libsss_sudo_la_LDFLAGS = \
sudolib_LTLIBRARIES = libsss_sudo.la
-include_HEADERS += \
- src/sss_client/sudo/sss_sudo.h
endif
if BUILD_AUTOFS
@@ -1850,9 +1849,6 @@ docs:
$(DOXYGEN) src/doxy.config
$(DOXYGEN) src/providers/ipa/ipa_hbac.doxy
$(DOXYGEN) src/lib/idmap/sss_idmap.doxy
-if BUILD_SUDO
- $(DOXYGEN) src/sss_client/sudo/sss_sudo.doxy
-endif BUILD_SUDO
$(DOXYGEN) src/sss_client/idmap/sss_nss_idmap.doxy
else !HAVE_DOXYGEN
docs: