summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2013-04-22 17:57:53 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-05-03 20:06:29 +0200
commitc080a11e9e88f35e40aff4e476cabbd971833019 (patch)
tree21e09bfcf64d754ea5236c089e0dc0655f9f5041 /Makefile.am
parent2a9af1f71887f02935e2fb6ad5023afba5b6d43e (diff)
downloadsssd-c080a11e9e88f35e40aff4e476cabbd971833019.tar.gz
sssd-c080a11e9e88f35e40aff4e476cabbd971833019.tar.xz
sssd-c080a11e9e88f35e40aff4e476cabbd971833019.zip
Add python interface to libsss_nss_idmap
To allow to use libsss_nss_idmap from python applications, e.g. the FreeIPA server, the patch adds pythin bindings to libsss_nss_idmap. The contributed spec file will place the python bindings in a new package called libsss_nss_idmap-python. Alexander Bokovoy <abokovoy@redhat.com> kindly provided the code to check the type of the python objects and loop over the list entries.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 85c754c82..192486670 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -228,7 +228,8 @@ if BUILD_PYTHON_BINDINGS
pyexec_LTLIBRARIES = \
pysss.la \
pyhbac.la \
- pysss_murmur.la
+ pysss_murmur.la \
+ pysss_nss_idmap.la
endif
dist_noinst_SCRIPTS = \
@@ -1750,6 +1751,18 @@ pysss_murmur_la_LIBADD = \
pysss_murmur_la_LDFLAGS = \
-avoid-version \
-module
+
+pysss_nss_idmap_la_SOURCES = \
+ src/python/pysss_nss_idmap.c
+pysss_nss_idmap_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(PYTHON_CFLAGS)
+pysss_nss_idmap_la_LIBADD = \
+ $(PYTHON_LIBS) \
+ libsss_nss_idmap.la
+pysss_nss_idmap_la_LDFLAGS = \
+ -avoid-version \
+ -module
endif
################