summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2012-10-20 03:07:27 -0400
committerSimo Sorce <simo@redhat.com>2013-01-10 12:24:59 -0500
commit918b2a5a91f1c551d48f4bffed2a28c36fdb4be1 (patch)
tree090b1dfb4b592a5187e986c08f5645feef88c51c /Makefile.am
parentc63415eabb1dc595c60760fb1df7fa7cfd1d3200 (diff)
downloadsssd-918b2a5a91f1c551d48f4bffed2a28c36fdb4be1.tar.gz
sssd-918b2a5a91f1c551d48f4bffed2a28c36fdb4be1.tar.xz
sssd-918b2a5a91f1c551d48f4bffed2a28c36fdb4be1.zip
Add authtok utility functions.
These functions allow handling of auth tokens in a completely opaque way, with clear semantics and accessor fucntions that guarantee consistency, proper access to data and error conditions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 85eee66d7..3eb8cc021 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -369,6 +369,7 @@ dist_noinst_HEADERS = \
src/util/mmap_cache.h \
src/util/atomic_io.h \
src/util/auth_utils.h \
+ src/util/authtok.h \
src/monitor/monitor.h \
src/monitor/monitor_interfaces.h \
src/responder/common/responder.h \
@@ -508,6 +509,7 @@ libsss_util_la_SOURCES = \
src/util/sss_tc_utf8.c \
src/util/murmurhash3.c \
src/util/atomic_io.c \
+ src/util/authtok.c \
src/util/sss_selinux.c \
src/util/domain_info_utils.c \
src/util/util_lock.c